import Foundation
let pattern = #"^http:..|^https:..|\/.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://www.asd.google.com
https://www.google.net
https://www.google.co.nz
https://google.com
https://www.google.com/api?=login/someshit
https://www.google.com/ads/getmeadrink/api?0284230284782487871837871301-0/
www.google.com/ads/v1/api?139305u30u130130/quote/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)