const regex = /zoom_[a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('zoom_[a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9]', 'gm')
const str = `zoom_asol2j
zoomea
zoom_sikwna
zoom_2j38sd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}