re = /zoom_[a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9]/m
str = 'zoom_asol2j
zoomea
zoom_sikwna
zoom_2j38sd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end