$re = '/(?<mylevel>\w{4,5})/m';
$str = 'INFO - Service Started
DEBUG - Service suspended
hei what is my field
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);