re = /(?<mylevel>\w{4,5})/m
str = 'INFO - Service Started
DEBUG - Service suspended
hei what is my field
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end