#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.ofType\(core\.([A-Z_]*.)\)"
Local $sString = ".ofType(core.REJECT_PENNG_USER)" & @CRLF & _
".ofType(core.REJECT_PDING_USER)" & @CRLF & _
".ofType(core.REJT_PENDING_USER)" & @CRLF & _
".ofType(core.REJET_PENDING_USER)" & @CRLF & _
".ofType(core.REJECT_PENDISER)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")