re = /\.ofType\(core\.([A-Z_]*.)\)/m
str = '.ofType(core.REJECT_PENNG_USER)
.ofType(core.REJECT_PDING_USER)
.ofType(core.REJT_PENDING_USER)
.ofType(core.REJET_PENDING_USER)
.ofType(core.REJECT_PENDISER)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end