import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{IF\\s*([^\\}]+)\\}([\\s\\S]+)(?:\\{\\/?ELSE\\})([\\s\\S]+?)\\{\\/IF\\}";
final String string = "{IF !isLoggedIn}\n"
+ " <a href=\"/sign-in/\">Sign In</a>\n"
+ "{ELSE}\n"
+ " Welcome back, {>username}!<br />\n"
+ " {# students}\n"
+ " <li>{#>last_name}, {#>first_name}</li>\n"
+ " {/#}\n"
+ "{/IF}\n\n"
+ "{IF isLoggedIn}\n"
+ " Beta Testing...\n\n"
+ "{/IF}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}