import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s): \\[.+?\\r?\\n \\]";
final String string = "\"before\"\n"
+ ": [\n"
+ " {\n"
+ " \"yearGroupId\": 13,\n"
+ " \"educationPhaseEnum\": 2,\n"
+ " \"name\": \"Year Group 12\",\n"
+ " \"label\": \"YG 12\"\n"
+ " },\n"
+ " {\n"
+ " \"yearGroupId\": 14,\n"
+ " \"educationPhaseEnum\": 2,\n"
+ " \"name\": \"Year Group 13\",\n"
+ " \"label\": \"YG 13\"\n"
+ " }\n"
+ " ]\n"
+ "\"after\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}