import re
regex = re.compile(r"%([^%.]+)%|(?<!\$)\$(?:\{([^{}]+)\}|([^$.\s]+))", flags=re.MULTILINE)
test_str = ("%ABC%\n"
"$ABC.\n"
"$ABC$XYZ\n\n"
"To add a bit more to this:\n\n"
"${ABC}\n\n"
" should yield ABC too. (ignore curly braces if present - non capture chars perhaps?).\n"
"if you have two successive dollar signs, such as \"$$EFG\", or \"$${EFG}\",\n"
"that should not appear in a regex result. (This is where either numbered or named back- references come into play - and the reason I contemplated them as non-capture groups). As I understand it, a group becomes a non-capture group with this syntax (?:).")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")