const regex = /^\/root\/[^\/\n]+(?:\/index\.shtml)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/root\\\/[^\\\/\\n]+(?:\\\/index\\.shtml)?$', 'gm')
const str = `/root/index.shtml
/root/root_one.shtml
/root/one/index.shtml
/root/two/index.shtml
/root/two/test.shtml
/root/two/three/index.shtml
/root/2024/index.shtml
/root/2024/one.shtml`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}