$re = '/^\/root\/[^\/\n]+(?:\/index\.shtml)?$/m';
$str = '/root/index.shtml
/root/root_one.shtml
/root/one/index.shtml
/root/two/index.shtml
/root/two/test.shtml
/root/two/three/index.shtml
/root/2024/index.shtml
/root/2024/one.shtml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);