// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/root\/[^\/\n]+(?:\/index\.shtml)?$").unwrap();
let string = "/root/index.shtml
/root/root_one.shtml
/root/one/index.shtml
/root/two/index.shtml
/root/two/test.shtml
/root/two/three/index.shtml
/root/2024/index.shtml
/root/2024/one.shtml";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}