package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\u0021-\u002f\u003a-\u0040\u005b-\u0060\u007b-\u008f\u00a0-\u00bf\u00d7\u00f7\u2000-\u2bff\u3000-\u303f]`)
var str = `-・·&%'・·關∞|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}