re = /[\u0021-\u002f\u003a-\u0040\u005b-\u0060\u007b-\u008f\u00a0-\u00bf\u00d7\u00f7\u2000-\u2bff\u3000-\u303f]/m
str = '-・·&%\'・·關∞|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end