import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^arn:(?P<Partition>[^:\\n]*):(?P<Service>[^:\\n]*):(?P<Region>[^:\\n]*):(?P<AccountID>[^:\\n]*):(?P<Ignore>(?P<ResourceType>[^:\\/\\n]*)[:\\/])?(?P<Resource>.*)$";
final String string = "# ARN Format Templates\n"
+ "arn:partition:service:region:account-id:resource\n"
+ "arn:partition:service:region:account-id:resourcetype/resource\n"
+ "arn:partition:service:region:account-id:resourcetype:resource\n\n"
+ "# Amazon Simple Storage Service (S3)\n"
+ "arn:aws:s3:::my_corporate_bucket/Development/*\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}