using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"B(?=.{8,11}$)|B(?=.{0,3}$)";
string input = @"AAAABBBBAAAA
ABAABBBBAAAA
AAAABBBBABAA
BAAABBBBAAAB";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}