$re = '/[^a-zA-Z0-9$%&*+\/\-]/m';
$str = 'WZ 123456--12.123.45678';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;