re = /[^a-zA-Z0-9$%&*+\/\-]/m
str = 'WZ 123456--12.123.45678'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result