$re = '/(#.*)[:|\s]{1}/mi';
$str = '#foobar
.body #foobar
#foobar:hover
#bar:hover ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);