$re = '/abc/m';
$str = 'abc
abc
abc
sda
asdasd
sad
sd
s
d
sad
asd
asd
sabc
abc
asdsad
sd
s
d
sad
sa
dsad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);