re = /\$(?:{([_a-zA-Z0-9]+)}|([_a-zA-Z0-9]+))\b/m
str = '$verb = verb
${verb}age = verb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end