// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:MP)([0-9]{1,}|[0-9]{1,}\.|\.[0-9]{1,}|[0-9]{1,}\.[0-9]{1,}|)(?:\s{1,})(.{1,})").unwrap();
let string = "MP1 Chicago
MP7 Chicago
MP1. Chicago
MP7. Chicago
MP.1 Chicago
MP.7 Chicago
MP1.1 Chicago
MP7.7 Chicago
MP1Chicago
MP7Chicago
MP1.Chicago
MP7.Chicago
MP.1Chicago
MP.7Chicago
MP1.1Chicago
MP7.7Chicago";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}