re = /[^a-zA-Z0-9_,](?:\d{1,3},)*\d{1,3}\.\d\d\b/m
str = 'Hey Boss:
Just so you know, I did all the crimes. Like 100 of them. So many crimes.
We should probably delete this e-mail before we get sued.
xoxoxo,
Lackey.
Crime, INC.
For services rendered:
Tax Fraud 100.00
Price-fixing 9.99
Insider trading 20.00
TOTAL 129.99
Here is a stupid number .00
And here is another stupid number 1,000000,000.00
Dear Boss:
Remember all those crimes I\'ve committed? They made the firm $1,280,012.05. Maybe a raise?
xoxoxo,
Lackey
p.s. Here\'s a large dollar amount that also would not have matched the previous regex, but will match the new one!: 1,000,000,000,000.00
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end