#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*({\"ABC\":\".*?\"}).*"
Local $sString = "{"ABC":"Hello"},{"DEF":"World"},{"GHI":"!!!"}"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)