$re = '/A\[(?<A>.+)\]\sB\[(?<B>.+)\]\sC\[(?<C>.+)\]/m';
$str = 'A[1020/09/09] B[1013/09/09] C[05-07-00000000-000-A-B-C]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);