#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\d,]+)[\s\D]*([\d,]+)[\s\D]*([\d,]+)[\s\D]*"
Local $sString = "23,6 x 34 x 17,1" & @CRLF & _
"14,5 x 55 x 22" & @CRLF & _
"14,5cm x 55 x 22cm" & @CRLF & _
"14,5cmx55x22cm" & @CRLF & _
"14,5 cmx55 cmx22 cm" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")