import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\d,]+)[\\s\\D]*([\\d,]+)[\\s\\D]*([\\d,]+)[\\s\\D]*";
final String string = "23,6 x 34 x 17,1\n"
+ "14,5 x 55 x 22\n"
+ "14,5cm x 55 x 22cm\n"
+ "14,5cmx55x22cm\n"
+ "14,5 cmx55 cmx22 cm\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}