#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\d\s*|^\()"
Local $sString = "1 555-555-5555" & @CRLF & _
"1 (555) 555-5555" & @CRLF & _
"5555555555" & @CRLF & _
"555-555-5555" & @CRLF & _
"(555)555-5555" & @CRLF & _
"1(555)555-5555" & @CRLF & _
"1 555 555 5555" & @CRLF & _
"1 456 789 4444"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")