# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\W\d_])|./\1/gm;t' <<< "ABCŁąć1-2!Абв3§4“5def”"