package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\W\d_])|.`)
var str = `ABCŁąć1-2!Абв3§4“5def”`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}