const regex = /^UC-000(?:0\d|[1-9]\d*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^UC-000(?:0\\d|[1-9]\\d*)$', 'gm')
const str = `UC-00001
UC-00012
UC-000100
UC-00001
UC-00010
UC-00000
UC-000010
UC-0000100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}