package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[5][0-9]{8}$`)
var str = `523654789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}