$re = '/((?:[a-zA-Z0-9]+)? ?(?:[Ll]ist|[Tt]able|[Ff]igure)).*?((?:[0-9]+\-[0-9]+)|(?<!-)[0-9]+): (.*)/m';
$str = 'Text Table 6-2: Management of children study and actions
Table 6-2: Management of children study and actions
table 6-2: Management of children study and actions
tezt Text Table 6-22: Management of children study and actions
Tezt text table 66-2: Management of children study and actions
tezt Text List / 6-2: Management of children study and actions
Text list 6-2: Management of children study and actions
Table 6-2: Management of children study and actions
table 6-2: Management of children study and actions
tezt Text figure 6-22: Management of children study and actions
Tezt text Figure 66-2: Management of children study and actions
tezt Text Table / 6-2: Management of children study and actions
table: 66-22: Management of children study and actions
tezt Text Table 6-22: Management of children study and actions
tezt Text Table 6: Management of children study and actions
able 6-2: Management of children study and actions
re hable 6-2: Management of children study and actions
table 62: Management of children study and actions
table 62-: Management of children study and actions
table -2: Management of children study and actions
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);