$re = '/^(?:a(?:b(?:cd?)?)?)+$/m';
$str = 'a
abc
ab
babcd
aaaa
baa
the
acd
ad
cd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);