$re = '/(?:\w+(?:\.|\b)){3}/m';
$str = 'AAAA cccc.google.com BBBB
;kasjdlksajd www.google.com adsad
;lkasd regex101.com adsad
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);