import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/(?<domain>[^:\\/\\?,]*)";
final String string = "https://www.example.com:9090\n"
+ "https://abc.example-url.uk/username/test\n"
+ "https://test-url.web-url.ch/test\n"
+ "https://hello.example.co?test\n"
+ "https://test.example.com,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}