import Foundation
let pattern = #"(?<=\n\n).+(?=\n\n)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
The time will come when, with elation, you will greet yourself arriving at your own door, in your own mirror, and each will smile at the other's welcome, and say, sit here. Eat. You will love again the stranger who was your self. Give wine. Give bread. Give back your heart to itself, to the stranger who has loved you
all your life, whom you ignored for another, who knows you by heart. Take down the love letters from the bookshelf,
the photographs, the desperate notes, peel your own image from the mirror. Sit. Feast on your life.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)