re = /[^\n\x20-\x7f]/m
str = 'DELTA DIŞ TİCARET A.Ş.
DELTA DIŞ TİCARET A.Ş.
DELTA DIŞ TİCARET A.Ş.
'
subst = '?'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result