using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@due(\((?>[^()\/]|(?1))*+\))";
string input = @"aaa @tag @due(test(a(a)))() bbb @high @beephigh";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}