// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^[-ʻ'`a-zġūĀñēöåàíáüóéōāī ]+$").unwrap();
let string = "https://en.wikipedia.org/wiki/List_of_U.S._cities_with_diacritics
Alaska
Alaska
Utqiaġvik
American Samoa
Āfono
Ālega
'Āmanave
Āmouli
Aūa
Fagasā
Faleāsao
Lumā
Tāfuna
California
La Cañada Flintridge
Piñon Hills
San José
Colorado
Cañon
Cañon City
Piñon
Piñon
Piñon Acres
Guam
Hagåtña
Hagåtña Heights
Hawaii
ʻĀhuimanu
ʻ````Āinaloa
Hanapēpē
Haʻikū-Pauwela
Hālawa
Hāliʻimaile
Hāmoa
Hāna
Hāʻōʻū
Hāwī
Hīlea
Hōlualoa
Hōnaunau-Nāpōʻopoʻo
Honokōhau
Hoʻōpūloa
Kāʻanapali
Kaimū
Kākiʻo
Kalāheo
Kamalō
Kāneʻohe
Kaupō
Kaʻūpūlehu
Keālia
Kēōkea
Kēōkea
Kīhei
Kīholo
Kīlauea
Kīpahulu
Kīpū
Kōloa
Kūkaʻiau
Kūkiʻo
Lāʻie
Lānaʻi City
Laupāhoehoe
Lāwaʻi
Līhuʻe
Māʻalaea
Māʻili
Mākaha
Mākaha Valley
Mākena
Mānā
Mokulēʻia
Mōpua
Mūʻolea
Nāʻālehu
Nāhiku
Nānākuli
Nānāwale Estates
Nāpili-Honokōwai
Nīnole
Nīnole
ʻŌmaʻo
ʻŌmaʻopio
ʻŌʻōkala
Pāʻauhau
Pāhala
Pāhoa
Pāʻia
Pākalā Village
Pālehua
Pāpā Bay Estates
Pāpaʻaloa
Pāpaʻikou
Poʻipū
Puaʻākala
Pūʻālaʻa
Puakō
Pūkoʻo
Pūlehu
Pūpūkea
Puʻunēnē
Wahiawā
Wahīlauhue
Waikāne
Waikapū
Waimānalo
Waimānalo Beach
Waiʻōhinu
Waipāhoehoe
Welokā
Louisiana
Pointe à la Hache
West Pointe à la Hache
Minnesota
Arnesén
Lindström
New Mexico
Cañada de los Alamos
Cañon
Cañon
Cañoncito
Cañoncito
Cañoncito
Cañoncito
Cañones
Doña Ana
Española
Lower Cañones
Peña Blanca
Peñasco
Peñasco Blanco
Piñon
Señorito
Puerto Rico
Añasco
Bayamón
Canóvanas
Cataño
Comerío
Guánica
Juana Díaz
Las Marías
Loíza
Manatí
Mayagüez
Peñuelas
Rincón
Río Grande
San Germán
San Sebastián
Cañabón
Castañer
Río Piedras
Texas
César Chávez
La Peñusca
Lopeño
Salineño
Salineño North
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}