$re = '/\w{3,}\b(?!\()/m';
$str = 'T.name.other_name.another_name
T.name.again_name.ect_name.last_name()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);