re = /\w{3,}\b(?!\()/m
str = 'T.name.other_name.another_name
T.name.again_name.ect_name.last_name()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end