// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^0-9]*\b(([1-9]|1[0-9]|22|2[4-9]|[3-9][0-9]|1[0-2][0-9]|13[0-6]|1[4-9][0-9]|[2-9][0-9][0-8]|[1-9][0-9]{3}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5])\b[^0-9]*)*$)").unwrap();
let string = "56;45;5623;67;21;68
45;568;56564;68;254;136
8080;8958;368;65;80;443;22
8080;22;140
139;852;21;80
65;80;135
65;139
54;98;35;65;2 ;45
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}