// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+?56){0,1}(9)[98765]\d{7}$").unwrap();
let string = "+56932165481
965432189
+56986549874
+56965487d+ 56 9
+56 9 87135689
+569 8765321
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}