re = /(?:(?:(\w[\w\-]*\w)(?:@(.+))?):)?(.+)/
str = 'instance_name@region:/file/path
instance_name:/file/path
/file/path'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end