import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!Bauxite|Iridium))+(\\w)+(\\s)(dust)+$";
final String string = "Purified copper ore\n"
+ "Purified copper dust\n"
+ "Copper dust\n"
+ "Bauxite dust\n"
+ "Iridium dust\n"
+ "Small copper dust\n"
+ "Tiny copper dust\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}