import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[a-z]+(?:_[a-z]+)*)(?<!_cat|_uom)\\b";
final String string = "xxx_yyyyyy_zzz_aaaaa\n"
+ "xxx_cat_zzz_aaaaa\n"
+ "xxx_yyyyyy_zzz_aaaaa_cat\n"
+ "xxx_yyyyyy_zzz_aaaaa_uom";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}