// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(import)(?:.*?(as))?(?:.*?(as))?(?:.*?(from))*.*$").unwrap();
let string = "import \"./test\"
import \"./test\" as Test
import { Test } from \"./test\"
import { Person as Individual } from \"./test\"
import { Person as Individual, Test, Bag as Backpack } from \"./test\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}