import Foundation
let pattern = #"(^\s+_[A-Za-z]+\._)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
was from an authentic copy, and a careful comparison of the text with
the earlier one shows that in the meantime the play "underwent revision,
received some slight augmentation, and in some few places must have been
entirely rewritten." A marked instance of this rewriting--the only one
of considerable length--is in ii. 6. 6-37, where the first quarto reads
thus (spelling and pointing being modernized):--
_Jul._ Romeo.
_Rom._ My Juliet, welcome. As do waking eyes
Closed in Night's mists attend the frolick Day,
So Romeo hath expected Juliet,
And thou art come.
_Jul._ I am, if I be Day,
Come to my Sun: shine forth and make me fair.
_Rom._ All beauteous fairness dwelleth in thine eyes.
_Jul._ Romeo, from thine all brightness doth arise.
_Fri._ Come, wantons, come, the stealing hours do pass,
Defer embracements till some fitter time.
Part for a while, you shall not be alone
Till holy Church have joined ye both in one.
_Rom._ Lead, holy Father, all delay seems long.
_Jul._ Make haste, make haste, this lingering doth us wrong.
For convenient comparison I quote the later text here:--
_Juliet._ Good even to my ghostly confessor.
_Friar Laurence._ Romeo shall thank thee, daughter, for us both.
_Juliet._ As much to him, else is his thanks too much.
_Romeo._ Ah, Juliet, if the measure of thy joy
Be heap'd like mine and that thy skill be more
To blazon it, then sweeten with thy breath
This neighbour air, and let rich music's tongue
Unfold the imagin'd happiness that both
Receive in either by this dear encounter.
_Juliet._ Conceit, more rich in matter than in words,
Brags of his substance, not of ornament.
They are but beggars that can count their worth;
But my true love is grown to such excess
I cannot sum up half my sum of wealth.
_Friar Laurence._ Come, come with me, and we will make short work;
For, by your leaves, you shall not stay alone
Till holy church incorporate two in one.
The "omission, mutilation, or botching" by which some German editors
would explain all differences between the earlier and later texts will
not suffice to account for such divergence as this. "The two dialogues
do not differ merely in expressiveness and effect; they embody different
conceptions of the characters;" and yet we cannot doubt that both were
written by Shakespeare.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)